CD32 – Totally dead

Got a Amiga CD32 for repair. It doesn’t work, no video output, power LED does not fully illuminate on powering up the machine, so no reset on Power cycle. First thing that came up in my mind was the voltage detector, replaced it and the machine boots again. But video output is totally mangled. Checked […]

Read More

Amiga CD32 – works for 2-5 minutes

Problem Amiga CD32 was getting black/gray screen after 2-5 minutes. Solution The voltage at the voltage detector (U14) was getting under the threshold of 4.3V, which causes that the reset signal was pulled down, and causes the black/grey screen. I replaced the Voltage detector (u14), the 10K resistor (R629) and capacitor (C629). The last two […]

Read More

Amiga 600 in reboot loop

Amiga 600 which was constantly rebooting. I got this machine as a repair, someone before me tried to do a recap to the machine.. After that it was not working anymore. First thing I tried was to replace the 555 Timer (U14) and the C612 Capacitor, because this is common problem on an Amiga 600. […]

Read More

Amiga 1200 black screen on RGB output

Black screen on RGB output can be a broken E263R Ferrite Bead (FB200). Monitor won’t get into RGB mode if there is no 5V on pin 23. I have seen several Ferrite Beads that were broken, and have a much higher resistance (impedance). After replacement 5V is restored and we have RGB signal again.  

Read More

Amiga 600 IDE port replacement

Amiga 600 with HD boot problems. This board had a recap because it leaked from the caps. Some electrolyte leaked under the IDE header and a corroded the pins. Sometimes after reseating the IDE cable it booted, but mostly it didn’t boot. I removed the IDE header cleaned the mess underneath it and placed a […]

Read More