A1200 Rev 1B & A600 Rev 2B – Audio too loud

If the audio of your Amiga 1200 Rev 1B, A600 Rev 2B or maybe other revisions is too loud (not distorted), that is caused by two resistors. Tristan Zondag confirmed the A600 Rev 2B is also affected. R331 & R321 are 1,5K Ohm, while they should be 680 Ohm. If I test the output voltage […]

Read More

Amiga 500,500+,2000,3000 drive selector switch

How does it work On the Amiga 500,500+,2000,3000 you can’t boot from the external (DF1) drive by default, so you need a switch so the external (DF1) drive will act as DF0: Switch position 1 (default) Internal Drive is DF0: External Drive is DF1: Switch position 2 External Drive will be acting as DF0: Internal […]

Read More

Compact Flash LED not working

Some Compact Flash (CF) to IDE adaptors fail to light up the drive activity LED, I was wondering why… I took a board and removed some components and did some measurements, and I  discovered that the BOTH base pins of the NPN transistors are connected to ground. Huh?! That means that the transistors won’t switch […]

Read More

CDTV CDROM no data discs repair

This time a Commodore CDTV arrived on my workbench with the following symptoms: Plays audio cd fine Does not load CDROM (CDTV) discs After checking that the CD mechanism worked fine using an audio CD I tested with several CDTV discs both original and recordables. During loading the CD spins up OK and there is […]

Read More

Amiga 1200 Rev 1D1 Noise on video signal (LM385)

  I’ve seen some 1200 Rev. 1D.1 boards missing the D215 (LM385), this will result in a higher voltage on the DAC VREF signal (U30) and noise will shown when you dragging workbench windows, accessing HD or floppy, etc.. When you place a LM385 then the picture will be much better. If the LM385 is broke, […]

Read More